Note: The other languages of the website are Google-translated. Back to English

Как подсчитать символы в ячейке / диапазоне / листе в Excel?

Иногда вам может потребоваться подсчитать длину букв в ячейке, диапазоне или целой таблице в Excel, поэтому теперь я расскажу о методах, которые помогут вам сделать это быстро.

Подсчет символов в ячейке / диапазоне с формулами

Подсчитайте символы на всем листе с помощью Word

Подсчитайте количество определенного символа в строке с помощью Kutools for Excel хорошая идея3


Подсчет символов в ячейке / диапазоне с формулами

Если подсчитать только длину всех символов в ячейке, вы можете выбрать пустую ячейку и ввести эту формулу = LEN (A1) (A1 обозначает ячейку, в которой вы хотите посчитать буквы, вы можете изменить ее по своему усмотрению), затем нажмите Enter кнопку на клавиатуре, длина букв в ячейке подсчитана. Смотрите скриншот:

Внимание: Этот метод будет подсчитывать длину строки всех символов в указанной ячейке, включая числа, пробелы, специальные знаки и т. Д.

Но если вы хотите подсчитать символы в диапазоне, вы можете ввести эту формулу = СУММ (ДСТР (A1: B5)) (A1: B5 обозначает диапазон, в котором вы хотите подсчитать символы, вы можете изменить его по своему усмотрению), затем нажмите Ctrl + Shift + Enter кнопок на клавиатуре подсчитана длина символов в указанном диапазоне. Смотрите скриншот:




Подсчитайте символы на всем листе с помощью Word

Если вы хотите подсчитать все символы на всем листе, прямого способа подсчета их в Excel нет, это должно быть с помощью Word.

1. Откройте лист, в котором вы хотите посчитать буквы, и нажмите Ctrl + A чтобы выделить весь лист, затем скопируйте их в документ Word.

2. Затем в Word нажмите Обзор > Количество слов, см. снимок экрана:

3. Во всплывающем окне Количество слов диалоговом окне вы можете увидеть количество букв. Смотрите скриншот:


Подсчитайте количество определенного символа в строке с помощью Kutools for Excel

Если вы хотите подсчитать только появление определенного символа в строке, вы можете использовать Kutools for Excel's СЧЕТЧИК функция для быстрого подсчета количества символов в ячейке.

Kutools for Excel, с более чем 300 удобные функции, облегчающие вашу работу. 

После установки Kutools for Excel, пожалуйста, сделайте, как показано ниже :(Скачать бесплатно Kutools for Excel сейчас!)

1. Выберите ячейку, в которую вы хотите вывести результат подсчета, и нажмите Кутулс > Кутулс функции > Статистические и математические > СЧЕТЧИК . Смотрите скриншот:
количество символов 1

2. Затем в Аргументы функций диалоговом окне выберите строку, от которой вы хотите отсчитать до текстового поля, кроме Внутри_текст, и введите в двойных кавычках символ, который вы хотите посчитать в Найти_текст коробка. Смотрите скриншот:
количество символов 2

Примечание: Эта функция подсчитывает символы с учетом регистра.

3. Нажмите Ok , чтобы закрыть диалоговое окно, и перетащите маркер автозаполнения вниз, чтобы применить формулы к нужным ячейкам.
количество символов 3

Относительные статьи:


Лучшие инструменты для работы в офисе

Kutools for Excel решает большинство ваших проблем и увеличивает вашу производительность на 80%

  • Снова использовать: Быстро вставить сложные формулы, диаграммы и все, что вы использовали раньше; Зашифровать ячейки с паролем; Создать список рассылки и отправлять электронные письма ...
  • Бар Супер Формулы (легко редактировать несколько строк текста и формул); Макет для чтения (легко читать и редактировать большое количество ячеек); Вставить в отфильтрованный диапазон...
  • Объединить ячейки / строки / столбцы без потери данных; Разделить содержимое ячеек; Объединить повторяющиеся строки / столбцы... Предотвращение дублирования ячеек; Сравнить диапазоны...
  • Выберите Дубликат или Уникальный Ряды; Выбрать пустые строки (все ячейки пустые); Супер находка и нечеткая находка во многих рабочих тетрадях; Случайный выбор ...
  • Точная копия Несколько ячеек без изменения ссылки на формулу; Автоматическое создание ссылок на несколько листов; Вставить пули, Флажки и многое другое ...
  • Извлечь текст, Добавить текст, Удалить по позиции, Удалить пробел; Создание и печать промежуточных итогов по страницам; Преобразование содержимого ячеек в комментарии...
  • Суперфильтр (сохранять и применять схемы фильтров к другим листам); Расширенная сортировка по месяцам / неделям / дням, периодичности и др .; Специальный фильтр жирным, курсивом ...
  • Комбинируйте книги и рабочие листы; Объединить таблицы на основе ключевых столбцов; Разделить данные на несколько листов; Пакетное преобразование xls, xlsx и PDF...
  • Более 300 мощных функций. Поддерживает Office / Excel 2007-2019 и 365. Поддерживает все языки. Простое развертывание на вашем предприятии или в организации. Полнофункциональная 30-дневная бесплатная пробная версия. 60-дневная гарантия возврата денег.
вкладка kte 201905

Вкладка Office: интерфейс с вкладками в Office и упрощение работы

  • Включение редактирования и чтения с вкладками в Word, Excel, PowerPoint, Издатель, доступ, Visio и проект.
  • Открывайте и создавайте несколько документов на новых вкладках одного окна, а не в новых окнах.
  • Повышает вашу продуктивность на 50% и сокращает количество щелчков мышью на сотни каждый день!
офисный дно
Сортировать комментарии по
Комментарии (5)
Оценок пока нет. Оцените первым!
Этот комментарий был сведен к минимуму модератором на сайте
Эта формула считает символы, а не буквы, как следует из названия.
XLS
Этот комментарий был сведен к минимуму модератором на сайте
Копирование содержимого всего рабочего листа в слово, чтобы иметь возможность подсчитать количество символов в рабочем листе, — отличный совет! Большое тебе спасибо.
Дешрайдер ММ
Этот комментарий был сведен к минимуму модератором на сайте
NAOMBA NISAIDIE KUJUA IDADI YA ROW NA COLUM KWENYE EXCEL
ФЕТТИ
Этот комментарий был сведен к минимуму модератором на сайте
Извини? В чем твоя проблема?
Солнечно
Этот комментарий был сведен к минимуму модератором на сайте
Чтобы подсчитать все символы на листе: - Вместо того, чтобы копировать в Word, просто используйте формулу
'=СУММПРОИЗВ(ДЛСТР(A1:B5)) '.
Это работает, попробуйте!!
На самом деле SUM(LEN(A1:B5)) скорее всего завершится ошибкой с #VALUE! ошибка при использовании в больших диапазонах или в каждой ячейке много символов,
особенно в более старых версиях Excel, таких как Excel2000.

Итак, если вы получаете #VALUE! ошибки при использовании ' СУММ(ДЛСТР(A1:B5)) ', переключитесь на СУММПРОИЗВ.
Я предпочитаю это утомительному копированию в Word, потому что с СУММПРОИЗВ: -

1) Он легко работает на больших диапазонах, на любом типе форматирования ячеек.

2) Вы можете вычесть части диапазона, которые могут не иметь значения (например, ячейка, строка или столбец, содержащие личные заметки, не относящиеся к данным, которые вы хотите подсчитать).
например, =СУММПРОИЗВ(ДЛСТР(B1:L5799)) - ДЛСТР(C4) удаляет количество символов в ячейке C4 из всего диапазона B1:L5799
=СУММПРОИЗВ(ДЛСТР(B1:L5799)) - СУММПРОИЗВ(ДЛСТР(B462:L462)) удаляет количество символов в строке 462 из всего диапазона B1:L5799
=СУММПРОИЗВ(ДЛСТР(B1:L5799)) - СУММПРОИЗВ(ДЛСТР(D1:D5799)) удаляет количество символов в столбце D из всего диапазона B1:L5799

3) Вы можете добавлять диапазоны более чем на один лист, поэтому, не вставляя каждый лист в Word, вы можете получить общее количество. символов во всей рабочей тетради
например, =СУММПРОИЗВ(ДЛСТР(B3:L799))+СУММПРОИЗВ(ДЛСТР(Лист2!B4:C7))+СУММПРОИЗВ(ДЛСТР(Лист3!A1:C7000)) суммирует количество данных на 3 листах

4) Эти формулы будут обновляться по мере продвижения вашего рабочего листа - в противном случае вам придется продолжать вставлять в Word каждый раз, когда вы изменяете свои данные и нуждаетесь в пересмотренном количестве символов.

5) Он хранит вашу информацию в одном месте.

Предупреждение A) - Обе операции 'СУММПРОИЗВ(ДЛСТР(A1:B5))' и 'СУММ(ДЛСТР(A1:B5))' завершатся ошибкой, если какая-либо из отдельных ячеек в диапазоне содержит формулу, которая не может вычислить и выдает значение ошибки например #VALUE!, #NULL!, #REF!, #NUM!,#DIV/0! и т. д. Всегда лучше сочетать защиту от ошибок с вашими формулами в каждой ячейке.
Вы можете использовать защиту от ошибок для СУММПРОИЗВ, чтобы пометить ошибку, например '=ЕСЛИ(ЕОШИБКА(СУММПРОИЗВ(ДЛСТР(B4:C7))),"ошибка",СУММПРОИЗВ(ДЛСТР(B4:C7)))'
который выводит сообщение «err», если какая-либо ячейка содержит ошибку, но вы не можете получить количество символов в диапазоне, пока не будут исправлены ячейки, вызывающие ошибки, или диапазон не будет изменен, чтобы исключить ячейки, содержащие ошибка.
ЛЕТУЧАЯ МЫШЬ
Здесь еще нет комментариев
Оставляйте свои комментарии
Публикация как гость
×
Оценить этот пост:
0  Характеристики
Предлагаемые места