Перейти к основному содержанию

Excel Функция ЕОШИБКА

Автор: Аманда Ли Последнее изменение: 2022 июля 05 г.

Функция ЕОШИБКА возвращает ИСТИНА для любого типа ошибки (кроме #Н/Д) и ЛОЖЬ в противном случае.

функция ошибки 1


Синтаксис

=ISERR(value)


аргументы

  • значение (обязательно): Значение, которое вы хотите проверить, является ли оно ошибкой, кроме #N/A.

Возвращаемое значение

Функция ЕОШИБКА возвращает ИСТИНА или ЛОЖЬ.


Примечания к функциям

  • ISERR часто используется с функцией ЕСЛИ для отображения пользовательского сообщения или выполнения некоторых других вычислений при обнаружении ошибки, например, =ЕСЛИ(ISERR(A1);"сообщение"), =СУММ(--ISERR(A1:A10)).

Пример

Возьмите приведенную ниже таблицу в качестве примера. Чтобы проверить значения, перечисленные в таблице, на наличие ошибок, кроме #Н/Д, скопируйте или введите приведенную ниже формулу в верхнюю ячейку, нажмите Enter чтобы получить результат, а затем перетащите маркер заполнения (в правом нижнем углу ячейки результата) вниз, чтобы применить формулу к ячейкам ниже.

=ISERR(B3)

функция ошибки 2


Связанные функции

Функция ЕПУСТО в Excel

Функция ЕПУСТО возвращает ИСТИНА, если ячейка пуста или пуста, и ЛОЖЬ в противном случае.

Функция ЕОШИБКА Excel

Функция ЕОШИБКА возвращает ИСТИНА для любого типа ошибки и ЛОЖЬ в противном случае.

Excel НЕЛОГИЧЕСКАЯ функция

Функция ISLOGICAL возвращает TRUE для логического значения и FALSE в противном случае.

Функция Excel ISNA

Функция ISNONTEXT возвращает значение TRUE для значения ошибки #Н/Д и FALSE в противном случае.

Excel Функция НЕТТЕКСТ

Функция ISNONTEXT возвращает TRUE для значения, не являющегося текстом, и FALSE в противном случае.

Функция ЕЧИСЛО в Excel

Функция ISNUMBER возвращает значение TRUE для числа и FALSE в противном случае.

Функция Excel ISREF

Функция ISREF возвращает TRUE для ссылки и FALSE в противном случае.

Функция Excel ИСТЕКСТ

Функция ИСТЕКСТ возвращает ИСТИНА для текстового значения и ЛОЖЬ в противном случае.


Лучшие инструменты для работы в офисе

Kutools for Excel - поможет вам выделиться из толпы

🤖 Kutools AI Помощник: Революционный анализ данных на основе: Интеллектуальное исполнение   |  Генерировать код  |  Создание пользовательских формул  |  Анализ данных и создание диаграмм  |  Вызов функций Kutools...
Популярные опции: Найдите, выделите или определите дубликаты  |  Удалить пустые строки  |  Объедините столбцы или ячейки без потери данных  |  Раунд без формулы ...
Супер ВПросмотр: Несколько критериев  |  Множественное значение  |  На нескольких листах  |  Нечеткий поиск...
Адв. Выпадающий список: Простой раскрывающийся список  |  Зависимый раскрывающийся список  |  Выпадающий список с множественным выбором...
Менеджер столбцов: Добавить определенное количество столбцов  |  Переместить столбцы  |  Переключить статус видимости скрытых столбцов  Сравнить столбцы с Выберите одинаковые и разные ячейки ...
Рекомендуемые функции: Сетка Фокус  |  Просмотр дизайна  |  Большой Формулный Бар  |  Менеджер книг и листов | Библиотека ресурсов (Авто текст)  |  Выбор даты  |  Комбинировать листы  |  Шифровать/дешифровать ячейки  |  Отправлять электронные письма по списку  |  Суперфильтр  |  Специальный фильтр (фильтровать жирным шрифтом/курсивом/зачеркиванием...) ...
15 лучших наборов инструментов12 Текст Инструменты (Добавить текст, Удалить символы ...)  |  50+ График Тип (Диаграмма Ганта ...)  |  40+ Практических Формулы (Рассчитать возраст по дню рождения ...)  |  19 Вносимые Инструменты (Вставить QR-код, Вставить изображение из пути ...)  |  12 Конверсия Инструменты (Числа в слова, Конверсия валюты ...)  |  7 Слияние и разделение Инструменты (Расширенные ряды комбинирования, Разделить ячейки Excel ...)  |  ... и более

Kutools для Excel может похвастаться более чем 300 функциями, Гарантия того, что то, что вам нужно, находится на расстоянии одного клика...

Описание


Вкладка Office - включение чтения и редактирования с вкладками в Microsoft Office (включая Excel)

  • Одна секунда для переключения между десятками открытых документов!
  • Уменьшите количество щелчков мышью на сотни каждый день, попрощайтесь с рукой мыши.
  • Повышает вашу продуктивность на 50% при просмотре и редактировании нескольких документов.
  • Добавляет эффективные вкладки в Office (включая Excel), как в Chrome, Edge и Firefox.
Comments (0)
No ratings yet. Be the first to rate!
There are no comments posted here yet
Leave your comments
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations