Note: The other languages of the website are Google-translated. Back to English

Как найти значение в ячейке со списком, разделенным запятыми в Excel?

Предположим, у вас есть столбец, содержащий значения, разделенные запятыми, такие как Sales, 123, AAA, и теперь вы хотите узнать, находится ли значение 123 в ячейке, разделенной запятыми, как вы можете это сделать? В этой статье будет представлен метод решения проблемы.

Найти значение в ячейке с разделенным запятыми списком с формулой


Найти значение в ячейке с разделенным запятыми списком с формулой

Следующая формула может помочь вам найти значение в ячейке со списком, разделенным запятыми, в Excel. Пожалуйста, сделайте следующее.

1. Выберите пустую ячейку, введите формулу. =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") в панель формул и нажмите клавишу Enter. Смотрите скриншот:

Внимание: в формуле A2 - это ячейка, содержащая значения, разделенные запятыми, которые вы найдете.

2. Продолжайте выделять ячейку результата и перетащите маркер заполнения вниз, чтобы получить все результаты. Если значение «123» находится в ячейках, разделенных запятыми, вы получите результат «Да»; в противном случае вы получите ответ «Нет». Смотрите скриншот:


Статьи по теме:


Лучшие инструменты для работы в офисе

Kutools for Excel решает большинство ваших проблем и увеличивает вашу производительность на 80%

  • Снова использовать: Быстро вставить сложные формулы, диаграммы и все, что вы использовали раньше; Зашифровать ячейки с паролем; Создать список рассылки и отправлять электронные письма ...
  • Бар Супер Формулы (легко редактировать несколько строк текста и формул); Макет для чтения (легко читать и редактировать большое количество ячеек); Вставить в отфильтрованный диапазон...
  • Объединить ячейки / строки / столбцы без потери данных; Разделить содержимое ячеек; Объединить повторяющиеся строки / столбцы... Предотвращение дублирования ячеек; Сравнить диапазоны...
  • Выберите Дубликат или Уникальный Ряды; Выбрать пустые строки (все ячейки пустые); Супер находка и нечеткая находка во многих рабочих тетрадях; Случайный выбор ...
  • Точная копия Несколько ячеек без изменения ссылки на формулу; Автоматическое создание ссылок на несколько листов; Вставить пули, Флажки и многое другое ...
  • Извлечь текст, Добавить текст, Удалить по позиции, Удалить пробел; Создание и печать промежуточных итогов по страницам; Преобразование содержимого ячеек в комментарии...
  • Суперфильтр (сохранять и применять схемы фильтров к другим листам); Расширенная сортировка по месяцам / неделям / дням, периодичности и др .; Специальный фильтр жирным, курсивом ...
  • Комбинируйте книги и рабочие листы; Объединить таблицы на основе ключевых столбцов; Разделить данные на несколько листов; Пакетное преобразование xls, xlsx и PDF...
  • Более 300 мощных функций. Поддерживает Office/Excel 2007-2021 и 365. Поддерживает все языки. Простое развертывание на вашем предприятии или в организации. Полнофункциональная 30-дневная бесплатная пробная версия. 60-дневная гарантия возврата денег.
вкладка kte 201905

Вкладка Office: интерфейс с вкладками в Office и упрощение работы

  • Включение редактирования и чтения с вкладками в Word, Excel, PowerPoint, Издатель, доступ, Visio и проект.
  • Открывайте и создавайте несколько документов на новых вкладках одного окна, а не в новых окнах.
  • Повышает вашу продуктивность на 50% и сокращает количество щелчков мышью на сотни каждый день!
офисный дно
Сортировать комментарии по
Комментарии (16)
Оценок пока нет. Оцените первым!
Этот комментарий был сведен к минимуму модератором на сайте
Доброе утро всем. У меня есть вопрос о том, как подсчитать определенные значения, разделенные запятыми, в одной ячейке в excel. результат 15. Есть ли формула в excel.
Этот комментарий был сведен к минимуму модератором на сайте
Да, в Excel есть функция, которая может сделать это за вас. Однако, как объяснялось в приведенной выше задаче, чтобы повысить точность ваших данных, добавьте запятую слева и справа от вашего списка и включите его в свой поиск. См. пример ниже:
, 15,215,15,155,45,1515,15,
=СЧЁТЕСЛИ(A1, ",15,")
Объяснение этой формулы следующее: =СЧЁТЕСЛИ(номер ячейки или диапазон, значение, которое вы ищете/подсчитываете)
Дайте мне знать, если вам нужен лучший пример.
Этот комментарий был сведен к минимуму модератором на сайте
Привет!
Это действительно крутая формула, но у нее есть... недостаток? ... что я не могу понять, как это обойти. «Недостаток» — неправильное слово, но я не могу придумать (сейчас 8:30 утра, понедельник) подходящего слова.
Когда вы ищете любую часть числа, вы получаете «да». Итак, следующие все возвращают «да»:
=ЕСЛИ(ЧИСЛО(ПОИСК(12,A2)),"да","нет")
=ЕСЛИ(ЧИСЛО(ПОИСК(23,A2)),"да","нет")
=ЕСЛИ(ЧИСЛО(ПОИСК(3,A2)),"да","нет")

Пробовал заключать числа в кавычки, не помогло. Формула отлично работает для примера использования, в котором все числа имеют одинаковую длину. Но если вы ищете более короткое число, которое появляется в строке, вы получите ложное срабатывание.
Есть ли более буквальная альтернатива слову «ПОИСК» (опять же, это слово? ха-ха)? 
Благодаря! 
Этот комментарий был сведен к минимуму модератором на сайте
Привет Скотт С., Вы имеете в виду поиск точной строки?
Этот комментарий был сведен к минимуму модератором на сайте
Привет, Кристал.
Да, я полагаю, что это способ сформулировать это. 
Текущее решение вернет «Да» для любой части числовой строки. Таким образом, числа 1, 2, 3, 12, 23 и 123 вернут «Да». 
Я пытался придумать решение, которое будет искать строку чисел и возвращать «Да» для точного совпадения. 
Этот комментарий был сведен к минимуму модератором на сайте
Привет, Скотт С., спасибо за ваш отзыв. Я еще не нашел решение и вернусь к вам, если я его нашел.
Этот комментарий был сведен к минимуму модератором на сайте
Я нашел решение для этого. Если вы добавите запятую слева и справа от вашего списка и включите их (как бутерброд) в свой поиск, это позволит вам найти точное совпадение. Пример ниже:
, 123,231,321,122,321,1,2,3,23,
ПОИСК(",23,")
Таким образом, поиск выполняется от одной запятой до другой, а не только части записи из списка. Надеюсь, это то, что вы искали?
Этот комментарий был сведен к минимуму модератором на сайте
Я нашел решение. Если вы добавите запятую слева и справа от вашего списка, функция поиска потребует точного совпадения от запятой до запятой. См. пример ниже:
=ЕСЛИ(ЧИСЛО(ПОИСК(",12,",A2)),"да","нет")

, 312,123,10,112,126,
Это вернет false, потому что нет переменной от запятой до запятой (,12,), которая соответствует поиску. 
Если вам нужны дополнительные разъяснения, дайте мне знать, и я опубликую лучший пример. У меня была такая же проблема при автоматизации отчета для моего босса, и у меня было прозрение. :)
Этот комментарий был сведен к минимуму модератором на сайте
Эй, я все еще не могу понять это. У меня все еще та же проблема. вместо использования числа в формуле я использую ссылку на ячейку. например, если я ищу «1» (Q $ 1) в (123, 25,29,200, 2, 1) ($ J2), это все еще дает мне ДА. Формула =ЕСЛИ(ЧИСЛО(ПОИСК(Q$XNUMX,$JXNUMX)),"да","нет")

PS: у меня большой набор данных, я не могу ставить запятые перед и после каждой ячейки. Буду признателен за решение
Этот комментарий был сведен к минимуму модератором на сайте
привет пожалуйста помогите

У меня есть таблица в Excel с двумя столбцами A и B, под A есть значение, например, ячейка A2 имеет 1,2,2,1,2,1,2 и т. д. (имеет только два числа 1 и 2, но нужно распознать только 1 и 2 во всей ячейке и никакого другого числа), а A3 имеет 1,1,1, а A4 имеет 0, A5 имеет 2,2,2,2, а A6 имеет 20. Я хочу, чтобы B2 возвращал значение для A2 как Азия , B3 — Африка, B4 — «Нет», B5 — «Америка» и B6 — «Европа». Я думал, что смогу использовать формулу if, но она не может распознавать числа, разделенные запятыми, и возвращаемое значение). Пожалуйста помоги
Этот комментарий был сведен к минимуму модератором на сайте
Как насчет этого, пожалуйста, мне нужно получить значения в A и приравнять их к цифрам в C и вернуть значения в B, разделенные запятыми, соответственно, в C.

Спасибо
Этот комментарий был сведен к минимуму модератором на сайте
Привет, Дункан,
Если вы используете Excel для 365, следующая формула может помочь решить проблему.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Эта формула работает только в Excel для 365. Для других версий Excel, отличных от Excel для 365, я не нашел формулы, которая ее обрабатывает.
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Этот комментарий был сведен к минимуму модератором на сайте
Привет всем, у меня есть ячейка, в которой несколько стран разделены запятыми
Пример: значение ячейки A2 равно (Индия, Япония, Малайзия, Большой Китай).
Столбец G содержит названия стран
Теперь мне нужно найти формулу, которая сравнивает значение из столбца G со значением в ячейке A2.
Если значение совпадает, вернуть true, иначе вернуть False.
Этот комментарий был сведен к минимуму модератором на сайте
Привет Мохини Верма,
Формулу можно изменить следующим образом:
=ЕСЛИ(ЧИСЛО(ПОИСК(G2,A2)),"ИСТИНА","ЛОЖЬ")
Этот комментарий был сведен к минимуму модератором на сайте
Эй, я все еще не могу понять это. У меня все еще та же проблема. вместо использования числа в формуле я использую ссылку на ячейку. например, если я ищу «1» (Q $ 1) в (123, 25,29,200, 2, 1) ($ J2), это все еще дает мне ДА. Формула =ЕСЛИ(ЧИСЛО(ПОИСК(Q$XNUMX,$JXNUMX)),"да","нет")

PS: у меня большой набор данных, я не могу ставить запятые перед и после каждой ячейки. Буду признателен за решение
Этот комментарий был сведен к минимуму модератором на сайте
Привет Хассам

Просто используйте следующую формулу без функции ЕСЛИ. Если число точно совпадает, вы получите результат "ИСТИНА", иначе вы получите результат"НЕПРАВДА".
=ЧИСЛО(НАЙТИ(",1,",","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Здесь еще нет комментариев
Оставляйте свои комментарии
Публикация как гость
×
Оценить этот пост:
0   Характеристики
Предлагаемые места

Подписывайтесь на Нас

Copyright © 2009 - www.extendoffice.ком. | Все права защищены. Питаться от ExtendOffice, | Карта сайта
Microsoft и логотип Office являются товарными знаками или зарегистрированными товарными знаками Microsoft Corporation в США и / или других странах.
Защищено Sectigo SSL