Note: The other languages of the website are Google-translated. Back to English

Как преобразовать 1-12 в название месяца в Excel?

Например, вы получили таблицу продаж, в которой месяцы отображаются в виде чисел, и вам необходимо преобразовать числа в обычные названия месяцев, как показано ниже. Есть идеи? Эта статья представит вам два решения.


Преобразование 1–12 в название месяца с помощью формулы

Собственно, мы можем применить ТЕКСТ функция для простого преобразования чисел (от 1 до 12) в обычные названия месяцев в Excel. Пожалуйста, сделайте следующее:

Выберите пустую ячейку рядом с таблицей продаж, введите формулу =TEXT(A2*29,"mmm") (Внимание: A2 - это первое число в списке месяцев, которое вы преобразуете в название месяца), а затем перетащите маркер автозаполнения вниз в другие ячейки.

Теперь вы увидите, что числа (от 1 до 12) преобразованы в обычные названия месяцев.


Преобразование 1-12 в название месяца с помощью Kutools for Excel

Как видите, ТЕКСТ функция может возвращать название месяца в другой ячейке. Но если у вас установлен Kutools for Excel, вы можете применить его Эксплуатация возможность напрямую заменять числа (от 1 до 12) названиями месяцев.

Kutools for Excel - Включает более 300 удобных инструментов для Excel. Полнофункциональная бесплатная пробная версия 30-день, кредитная карта не требуется! Get It Now

1. Выберите числа, которые вы преобразуете в названия месяцев в таблице продаж, и нажмите Кутулс > Больше > Эксплуатация. Смотрите скриншот:

2. В диалоговом окне «Инструменты работы», пожалуйста, (1) щелкните, чтобы выделить На заказ в Эксплуатация коробка; (2) введите формулу =TEXT(?*29,"mmm") в На заказ коробка; (3) проверить Создавать формулы вариант; и наконец (4) нажмите Ok кнопка. Смотрите скриншот:

Теперь вы увидите, что названия месяцев напрямую заменяют выбранные числа. Смотрите скриншот:


Статьи по теме:


Лучшие инструменты для работы в офисе

Kutools for Excel решает большинство ваших проблем и увеличивает вашу производительность на 80%

  • Снова использовать: Быстро вставить сложные формулы, диаграммы и все, что вы использовали раньше; Зашифровать ячейки с паролем; Создать список рассылки и отправлять электронные письма ...
  • Бар Супер Формулы (легко редактировать несколько строк текста и формул); Макет для чтения (легко читать и редактировать большое количество ячеек); Вставить в отфильтрованный диапазон...
  • Объединить ячейки / строки / столбцы без потери данных; Разделить содержимое ячеек; Объединить повторяющиеся строки / столбцы... Предотвращение дублирования ячеек; Сравнить диапазоны...
  • Выберите Дубликат или Уникальный Ряды; Выбрать пустые строки (все ячейки пустые); Супер находка и нечеткая находка во многих рабочих тетрадях; Случайный выбор ...
  • Точная копия Несколько ячеек без изменения ссылки на формулу; Автоматическое создание ссылок на несколько листов; Вставить пули, Флажки и многое другое ...
  • Извлечь текст, Добавить текст, Удалить по позиции, Удалить пробел; Создание и печать промежуточных итогов по страницам; Преобразование содержимого ячеек в комментарии...
  • Суперфильтр (сохранять и применять схемы фильтров к другим листам); Расширенная сортировка по месяцам / неделям / дням, периодичности и др .; Специальный фильтр жирным, курсивом ...
  • Комбинируйте книги и рабочие листы; Объединить таблицы на основе ключевых столбцов; Разделить данные на несколько листов; Пакетное преобразование xls, xlsx и PDF...
  • Более 300 мощных функций. Поддерживает Office/Excel 2007-2021 и 365. Поддерживает все языки. Простое развертывание на вашем предприятии или в организации. Полнофункциональная 30-дневная бесплатная пробная версия. 60-дневная гарантия возврата денег.
вкладка kte 201905

Вкладка Office: интерфейс с вкладками в Office и упрощение работы

  • Включение редактирования и чтения с вкладками в Word, Excel, PowerPoint, Издатель, доступ, Visio и проект.
  • Открывайте и создавайте несколько документов на новых вкладках одного окна, а не в новых окнах.
  • Повышает вашу продуктивность на 50% и сокращает количество щелчков мышью на сотни каждый день!
офисный дно
Сортировать комментарии по
Комментарии (16)
Номинальный 4.5 из 5 · рейтинги 2
Этот комментарий был сведен к минимуму модератором на сайте
Можете ли вы объяснить, почему в этой формуле число 29?
Этот комментарий был сведен к минимуму модератором на сайте
Текстовая формула обрабатывает число как день в году. Таким образом, 1 будет 1 января, а 365 будет 31 декабря. Если перевести эти числа в месяцы, то 1 будет январь, а 365 — декабрь. С 2 формула увидит это как 2 января, поэтому все равно вернется как январь. Однако с 29 мы можем вместо этого сделать 2 58, что намекает на 27 февраля. Таким образом, формула вернет это как февраль. То же самое относится и к числам от 1 до 12. Надеюсь, это поможет.
Этот комментарий был сведен к минимуму модератором на сайте
Вы также можете использовать 28 вместо 29 с теми же результатами.

30 не подойдет для февраля, а 27 — для декабря, поэтому единственные варианты — 28 и 29.
Этот комментарий был сведен к минимуму модератором на сайте
30 должен быть неудачным для февраля, но этого не происходит, потому что Excel ошибочно предполагает, что 1900 год был високосным.
27 фактически терпит неудачу в сентябре, октябре, ноябре и декабре.
Этот комментарий был сведен к минимуму модератором на сайте
Очень полезно! Огромное спасибо!
Этот комментарий был сведен к минимуму модератором на сайте
Gracias, me sirvio mucho tu explicación.
Этот комментарий был сведен к минимуму модератором на сайте
Коба ини..


=ТЕКСТ("1/" & A2 & "/2022" ; "м мм ммм мммм" )


Информация :
"1/" дибуат на танггал 1
Ячейка A2 ангка булан 1 - 12
"/2022" на тахун 2022
"м мм ммм мммм" в формате memilih.

Nanti hasilnya 4 04 апр апрель
Номинальный 4.5 из 5
Этот комментарий был сведен к минимуму модератором на сайте
Привет, вы пытаетесь получить список дат в формате: день/месяц/год?
Если это так, вы можете просто использовать следующую формулу: ="1/"&A2&"/2022".

Аманда
Этот комментарий был сведен к минимуму модератором на сайте
Можете ли вы объяснить, почему в этой формуле число 29?
Номинальный 4.5 из 5
Этот комментарий был сведен к минимуму модератором на сайте
Вы также можете использовать 28 вместо 29 с теми же результатами.
30 не подойдет для февраля, а 27 — для декабря, поэтому единственные варианты — 28 и 29.
John #30837
30 должен быть неудачным для февраля, но этого не происходит, потому что Excel ошибочно предполагает, что 1900 год был високосным.
27 фактически терпит неудачу в сентябре, октябре, ноябре и декабре.
Крис #30838

Привет, два приведенных выше комментария со страницы должны объяснить причину.
Если у вас есть другие вопросы, пожалуйста, не стесняйтесь спрашивать. :)

Аманда
Этот комментарий был сведен к минимуму модератором на сайте
есть ли способ сделать приведенный выше пример kutools без получения расширения? Например, я набираю в ячейке число от 1 до 12, и оно автоматически меняется на название месяца?
Этот комментарий был сведен к минимуму модератором на сайте
Всем привет,

Извините, что вы не можете сделать это напрямую.
Однако после того, как вы применили функцию, вы можете легко применить ее снова, щелкнув значок Повторно запустить последнюю утилиту Кнопка:
https://www.extendoffice.com/images/stories/comments/ljy-picture/re-run_utility.png

Вы можете нажать кнопку, чтобы повторно запустить последнюю утилиту, или щелкнуть стрелку раскрывающегося списка, чтобы выбрать последние примененные утилиты для повторного запуска.

Аманда
Этот комментарий был сведен к минимуму модератором на сайте
По какой-то причине ни формула ТЕКСТ (=ТЕКСТ(ссылка на ячейку;"мммм")), ни настройка пользовательского формата ячейки на мммм не работают - оба просто возвращают значение "00". Есть идеи, почему это происходит? Простое использование формулы МЕСЯЦ возвращает правильный номер месяца, поэтому проблема не может быть в формате даты.
Этот комментарий был сведен к минимуму модератором на сайте
Всем привет,

Я думаю, что формула в учебнике =ТЕКСТ(A2*29;"ммм"). И A2 в формуле есть число, скажем, 2, которое вы хотите преобразовать в текст месяца, скажем, февраль.

Аманда
Этот комментарий был сведен к минимуму модератором на сайте
Я получаю ту же проблему, единственным возвратом является «00», независимо от использования * 28 или * 29 в формуле. Столбец включает только числа 1-12, поэтому они в текстовом формате, поэтому я не могу понять проблему.
Этот комментарий был сведен к минимуму модератором на сайте
Всем привет,

Можете ли вы показать мне скриншот ваших данных?
Примечание. Выберите ячейку, в которую вы ввели формулу, а затем сделайте снимок экрана, содержащий как ваши данные, так и строку формул.

Аманда
Здесь еще нет комментариев
Оставляйте свои комментарии
Публикация как гость
×
Оценить этот пост:
0   Характеристики
Предлагаемые места

Подписывайтесь на Нас

Copyright © 2009 - www.extendoffice.ком. | Все права защищены. Питаться от ExtendOffice, | Карта сайта
Microsoft и логотип Office являются товарными знаками или зарегистрированными товарными знаками Microsoft Corporation в США и / или других странах.
Защищено Sectigo SSL