Note: The other languages of the website are Google-translated. Back to English

Как использовать vlookup и формат даты возврата вместо числа в Excel?

Функция vlookup часто используется в Excel для повседневной работы. Например, вы пытаетесь найти дату на основе максимального значения в указанном столбце с помощью формулы Vlookup. =VLOOKUP(MAX(C2:C8), C2:D8, 2, FALSE). Однако вы можете заметить, что дата отображается как серийный номер, а не в формате даты, как показано на скриншоте ниже. Есть ли какой-нибудь удобный способ справиться с этим, кроме ручного изменения форматирования ячеек на формат даты? Эта статья покажет вам простой способ решить эту проблему.

Формат Vlookup и даты возврата вместо числа в Excel


Формат Vlookup и даты возврата вместо числа в Excel

Если вы хотите получить дату на основе максимального значения в определенном столбце с помощью функции Vlookup и сохранить формат даты в ячейке назначения. Пожалуйста, сделайте следующее.

1. Введите эту формулу в ячейку и нажмите Enter ключ для получения правильного результата. Смотрите скриншот:

=TEXT(VLOOKUP(MAX(C2:C8), C2:D8, 2, FALSE),"MM/DD/YY")

Внимание: Пожалуйста, заключите формулу vlookup с ТЕКСТ() функция. И не забудьте указать формат даты в двойных кавычках в конце формулы.


Статьи по теме:


Лучшие инструменты для работы в офисе

Kutools for Excel решает большинство ваших проблем и увеличивает вашу производительность на 80%

  • Снова использовать: Быстро вставить сложные формулы, диаграммы и все, что вы использовали раньше; Зашифровать ячейки с паролем; Создать список рассылки и отправлять электронные письма ...
  • Бар Супер Формулы (легко редактировать несколько строк текста и формул); Макет для чтения (легко читать и редактировать большое количество ячеек); Вставить в отфильтрованный диапазон...
  • Объединить ячейки / строки / столбцы без потери данных; Разделить содержимое ячеек; Объединить повторяющиеся строки / столбцы... Предотвращение дублирования ячеек; Сравнить диапазоны...
  • Выберите Дубликат или Уникальный Ряды; Выбрать пустые строки (все ячейки пустые); Супер находка и нечеткая находка во многих рабочих тетрадях; Случайный выбор ...
  • Точная копия Несколько ячеек без изменения ссылки на формулу; Автоматическое создание ссылок на несколько листов; Вставить пули, Флажки и многое другое ...
  • Извлечь текст, Добавить текст, Удалить по позиции, Удалить пробел; Создание и печать промежуточных итогов по страницам; Преобразование содержимого ячеек в комментарии...
  • Суперфильтр (сохранять и применять схемы фильтров к другим листам); Расширенная сортировка по месяцам / неделям / дням, периодичности и др .; Специальный фильтр жирным, курсивом ...
  • Комбинируйте книги и рабочие листы; Объединить таблицы на основе ключевых столбцов; Разделить данные на несколько листов; Пакетное преобразование xls, xlsx и PDF...
  • Более 300 мощных функций. Поддерживает Office/Excel 2007-2021 и 365. Поддерживает все языки. Простое развертывание на вашем предприятии или в организации. Полнофункциональная 30-дневная бесплатная пробная версия. 60-дневная гарантия возврата денег.
вкладка kte 201905

Вкладка Office: интерфейс с вкладками в Office и упрощение работы

  • Включение редактирования и чтения с вкладками в Word, Excel, PowerPoint, Издатель, доступ, Visio и проект.
  • Открывайте и создавайте несколько документов на новых вкладках одного окна, а не в новых окнах.
  • Повышает вашу продуктивность на 50% и сокращает количество щелчков мышью на сотни каждый день!
офисный дно
Сортировать комментарии по
Комментарии (7)
Оценок пока нет. Оцените первым!
Этот комментарий был сведен к минимуму модератором на сайте
Моя формула =ТЕКСТ(ВПР(A2,I2:I931,2,ЛОЖЬ),"ММ/ДД/ГГ") дает мне #ССЫЛКА! ошибка. Любой совет?
Этот комментарий был сведен к минимуму модератором на сайте
вам нужна ссылка на абсолютное значение. с выбранным массивом нажмите клавишу F4 на клавиатуре, чтобы включить абсолютную ссылку в ваш массив.
Этот комментарий был сведен к минимуму модератором на сайте
мне нужна дата с помощью vlookup, но запись даты была 2 и 3 и более. Мне нужна последняя дата, когда заказ будет завершен, пожалуйста, помогите
Этот комментарий был сведен к минимуму модератором на сайте
моя дата меняется на другой год. моя формула = ТЕКСТ(ВПР(D4,'список платежей (2)'!$B$3:$I$694,7,0),"дд/мм/гггг")
Этот комментарий был сведен к минимуму модератором на сайте
Я пытаюсь выполнить ВПР на двух разных листах, это формула, которую я сделал, но она не работает:
=TEXT(VLOOKUP(MAX('Logging'!C9:C1250,Data!$A:$A),'Logging'!C9:C151:'Logging'!G9:G150, 5, FALSE),"DD/MM/YY")

Я хочу, чтобы дата из листа регистрации отображалась в листе данных, но рядом с его именем. Кто-нибудь знает, будет ли это обновляться с последней датой, если имя появится снова?
Этот комментарий был сведен к минимуму модератором на сайте
Был ответ, кто-то на моей работе знал, что делать. Для тех, кто хочет знать:
Вот формула, которую они использовали: =MAX(IF('Журналирование'!C:C=Данные!A2,'Журналирование'!G:G,0))
Этот комментарий был сведен к минимуму модератором на сайте
Мне нужно свидание для vlookup, но у даты есть формула. Пожалуйста помоги
Здесь еще нет комментариев
Оставляйте свои комментарии
Публикация как гость
×
Оценить этот пост:
0   Характеристики
Предлагаемые места

Подписывайтесь на Нас

Copyright © 2009 - www.extendoffice.ком. | Все права защищены. Питаться от ExtendOffice, | Карта сайта
Microsoft и логотип Office являются товарными знаками или зарегистрированными товарными знаками Microsoft Corporation в США и / или других странах.
Защищено Sectigo SSL