Note: The other languages of the website are Google-translated. Back to English

Как создать пятизвездочную рейтинговую систему в Excel? 

В нашей обычной жизни мы обычно применяем пятизвездочные рейтинги для оценки оценок продукта или удовлетворенности клиентов, как показано на следующем снимке экрана, но как вы могли бы создать пятизвездочную систему рейтингов в таблице Excel?

Создайте пятизвездочную рейтинговую систему с условным форматированием в Excel


Создайте пятизвездочную рейтинговую систему с условным форматированием в Excel

В Excel Условное форматирование Функция может помочь вам быстро создать простой пятизвездочный рейтинг. Для этого выполните следующие действия:

1. Введите числа от 1 до 5 в столбцы рядом с вашими данными, как показано на следующем снимке экрана:

2. Затем введите эту формулу: =IF(C$1<=$B3,1,IF(ROUNDUP($B3,0)=C$1,MOD($B3,1),0)) в ячейку C3 и перетащите маркер заполнения вниз к ячейкам, которые вы хотите заполнить этой формулой, см. снимок экрана:

Внимание: В приведенной выше формуле B3 содержит ли ячейка номер рейтинга, и C1 - это первая числовая ячейка, которую вы ввели на шаге 1.

3. И продолжайте перетаскивать дескриптор заполнения в правые ячейки, к которым вы хотите применить эту формулу, вы получите следующий результат, см. Снимок экрана:

4. Выделите ячейки формулы и нажмите Главная > Условное форматирование > Новое правило, см. снимок экрана:

5. В выскочившем Новое правило форматирования диалоговом окне выполните следующие действия:

(1.) Щелкните Отформатируйте все ячейки на основе их значений в Выберите тип правила список;

(2.) В Стиль формата раскрывающийся список, выберите Наборы иконок вариант;

(3.) Выберите 3 Звезды значок из Иконка Стиль раскрывающийся список;

(4.) Проверьте Показать только значок вариант;

(5.) В разделе правил введите 1 и 0.5 отдельно в Значение текстовое поле, и оба выбирают Число из Тип выпадающие списки.

6. Затем нажмите OK кнопки, пятизвездочные оценки были вставлены в ячейки, см. снимок экрана:


Лучшие инструменты для работы в офисе

Kutools for Excel решает большинство ваших проблем и увеличивает вашу производительность на 80%

  • Снова использовать: Быстро вставить сложные формулы, диаграммы и все, что вы использовали раньше; Зашифровать ячейки с паролем; Создать список рассылки и отправлять электронные письма ...
  • Бар Супер Формулы (легко редактировать несколько строк текста и формул); Макет для чтения (легко читать и редактировать большое количество ячеек); Вставить в отфильтрованный диапазон...
  • Объединить ячейки / строки / столбцы без потери данных; Разделить содержимое ячеек; Объединить повторяющиеся строки / столбцы... Предотвращение дублирования ячеек; Сравнить диапазоны...
  • Выберите Дубликат или Уникальный Ряды; Выбрать пустые строки (все ячейки пустые); Супер находка и нечеткая находка во многих рабочих тетрадях; Случайный выбор ...
  • Точная копия Несколько ячеек без изменения ссылки на формулу; Автоматическое создание ссылок на несколько листов; Вставить пули, Флажки и многое другое ...
  • Извлечь текст, Добавить текст, Удалить по позиции, Удалить пробел; Создание и печать промежуточных итогов по страницам; Преобразование содержимого ячеек в комментарии...
  • Суперфильтр (сохранять и применять схемы фильтров к другим листам); Расширенная сортировка по месяцам / неделям / дням, периодичности и др .; Специальный фильтр жирным, курсивом ...
  • Комбинируйте книги и рабочие листы; Объединить таблицы на основе ключевых столбцов; Разделить данные на несколько листов; Пакетное преобразование xls, xlsx и PDF...
  • Более 300 мощных функций. Поддерживает Office/Excel 2007-2021 и 365. Поддерживает все языки. Простое развертывание на вашем предприятии или в организации. Полнофункциональная 30-дневная бесплатная пробная версия. 60-дневная гарантия возврата денег.
вкладка kte 201905

Вкладка Office: интерфейс с вкладками в Office и упрощение работы

  • Включение редактирования и чтения с вкладками в Word, Excel, PowerPoint, Издатель, доступ, Visio и проект.
  • Открывайте и создавайте несколько документов на новых вкладках одного окна, а не в новых окнах.
  • Повышает вашу продуктивность на 50% и сокращает количество щелчков мышью на сотни каждый день!
офисный дно
Сортировать комментарии по
Комментарии (6)
Оценок пока нет. Оцените первым!
Этот комментарий был сведен к минимуму модератором на сайте
Тесты и функции формулы =SE(C$1<=$B3;1;SE(ARRED.PARA.CIMA($B3;0)=C$1;MOD($B3;1);0))
Этот комментарий был сведен к минимуму модератором на сайте
Французская формула: =SI(C$1<=$B3;1;SI(ARRONDI.SUP($B3;0)=C$1;MOD($B3;1);0))
Этот комментарий был сведен к минимуму модератором на сайте
Формула на испанском языке: =SI(C$1<=$B3;1;SI(REDONDEAR.MAS($B3;0)=C$1;RESIDUO($B3;1);0))
Этот комментарий был сведен к минимуму модератором на сайте
ПОЖАЛУЙСТА, ПОДЕЛИТЕСЬ С ФОРМУЛОЙ РЕЙТИНГА SULLIER В EXCEL
Этот комментарий был сведен к минимуму модератором на сайте
in Deutsch = =WENN(C$1<=$B3;1;WENN(AUFRUNDEN($B3;0)=C$1;REST($B3;1);0))
Этот комментарий был сведен к минимуму модератором на сайте
La формула на итальянском языке è: =SE(C$1<=$B3;1;SE(ARROTONDA.PER.ECC($B3,0)=C$1;RESTO($B3,1);0))
Здесь еще нет комментариев
Оставляйте свои комментарии
Публикация как гость
×
Оценить этот пост:
0   Характеристики
Предлагаемые места

Подписывайтесь на Нас

Copyright © 2009 - www.extendoffice.ком. | Все права защищены. Питаться от ExtendOffice, | Карта сайта
Microsoft и логотип Office являются товарными знаками или зарегистрированными товарными знаками Microsoft Corporation в США и / или других странах.
Защищено Sectigo SSL