Note: The other languages of the website are Google-translated. Back to English

Как усреднить абсолютные значения в Excel?

Если у вас есть список значений, который содержит как положительные, так и отрицательные числа, и теперь вы хотите вычислить среднее абсолютных значений этих чисел на листе. Есть ли у вас какие-нибудь хорошие идеи по решению этой проблемы?

Средние абсолютные значения в Excel со вспомогательным столбцом

Средние абсолютные значения в Excel с формулами

Средние абсолютные значения с Kutools for Excel хорошая идея3


Средние абсолютные значения в Excel со вспомогательным столбцом

Вообще говоря, вы можете использовать АБС функция, чтобы получить абсолютные значения всех чисел, а затем применить СРЕДНЯЯ функция для расчета результата. Пожалуйста, сделайте следующее:

1. Рядом со своими данными введите эту формулу: = ABS (A2), см. снимок экрана:

doc-средний-абс-значения1

2. Затем перетащите маркер заполнения в диапазон, в котором вы хотите применить эту формулу, и все значения будут преобразованы в абсолютные значения. Смотрите скриншот:

doc-средний-абс-значения1

3. Затем вы можете применить функцию СРЕДНЕЕ по типу = СРЕДНИЙ (B2: B13) (B2: B13 это диапазон, в котором вы хотите вычислить их среднее значение) в ячейку, чтобы получить среднее значение этих абсолютных значений, см. снимок экрана:

doc-средний-абс-значения1


Средние абсолютные значения в Excel с формулами

Может быть, описанный выше метод немного хлопотен, вот несколько простых формул, которые также могут вам помочь.

1. Введите эту формулу массива: = СРЕДНИЙ (ABS (A2: A13)) в пустую ячейку рядом с данными, см. снимок экрана:

doc-средний-абс-значения1

2, Затем нажмите Shift + Ctrl + Enter ключи вместе, чтобы вычислить результат.

doc-средний-абс-значения1

Примечание: Если вы хотите игнорировать 0 или пустые ячейки при усреднении абсолютных значений, вы можете использовать эту формулу массива: = СРЕДНЕЕ (ЕСЛИ (A2: A13 <> ""; ABS (A2: A13))), и не забудьте нажать Shift + Ctrl + Enter ключи.


Средние абсолютные значения с Kutools for Excel

Работы С Нами Kutools for Excel's Изменить знак ценностей утилита, вы можете сначала изменить все отрицательные значения на положительные, а затем применить = СРЕДНИЙ функция для получения среднего.

Kutools for Excel, с более чем 300 удобные функции, облегчающие вашу работу. 

После бесплатная установка Kutools for Excel, сделайте следующее:

1. Выберите значения и нажмите Кутулс > Содержание > Изменить знак ценностей. Смотрите скриншот:
документ 1

2. В появившемся диалоговом окне отметьте Измените все отрицательные значения на положительные вариант. Смотрите скриншот:
документ 2

3. Затем выберите пустую ячейку для ввода = СРЕДНИЙ (L1: L15) (L1: L15 - это значения, которые вы хотите получить в среднем) и нажмите Enter чтобы получить среднее.
документ 3


Статьи по теме:

Как усреднить ячейки, игнорируя значения ошибок в Excel?

Как усреднить только положительные или отрицательные числа в Excel?

Как усреднить диапазон данных, игнорируя ноль в Excel?

Как рассчитать среднее значение без максимальных и минимальных значений в Excel?


Лучшие инструменты для работы в офисе

Kutools for Excel решает большинство ваших проблем и увеличивает вашу производительность на 80%

  • Снова использовать: Быстро вставить сложные формулы, диаграммы и все, что вы использовали раньше; Зашифровать ячейки с паролем; Создать список рассылки и отправлять электронные письма ...
  • Бар Супер Формулы (легко редактировать несколько строк текста и формул); Макет для чтения (легко читать и редактировать большое количество ячеек); Вставить в отфильтрованный диапазон...
  • Объединить ячейки / строки / столбцы без потери данных; Разделить содержимое ячеек; Объединить повторяющиеся строки / столбцы... Предотвращение дублирования ячеек; Сравнить диапазоны...
  • Выберите Дубликат или Уникальный Ряды; Выбрать пустые строки (все ячейки пустые); Супер находка и нечеткая находка во многих рабочих тетрадях; Случайный выбор ...
  • Точная копия Несколько ячеек без изменения ссылки на формулу; Автоматическое создание ссылок на несколько листов; Вставить пули, Флажки и многое другое ...
  • Извлечь текст, Добавить текст, Удалить по позиции, Удалить пробел; Создание и печать промежуточных итогов по страницам; Преобразование содержимого ячеек в комментарии...
  • Суперфильтр (сохранять и применять схемы фильтров к другим листам); Расширенная сортировка по месяцам / неделям / дням, периодичности и др .; Специальный фильтр жирным, курсивом ...
  • Комбинируйте книги и рабочие листы; Объединить таблицы на основе ключевых столбцов; Разделить данные на несколько листов; Пакетное преобразование xls, xlsx и PDF...
  • Более 300 мощных функций. Поддерживает Office/Excel 2007-2021 и 365. Поддерживает все языки. Простое развертывание на вашем предприятии или в организации. Полнофункциональная 30-дневная бесплатная пробная версия. 60-дневная гарантия возврата денег.
вкладка kte 201905

Вкладка Office: интерфейс с вкладками в Office и упрощение работы

  • Включение редактирования и чтения с вкладками в Word, Excel, PowerPoint, Издатель, доступ, Visio и проект.
  • Открывайте и создавайте несколько документов на новых вкладках одного окна, а не в новых окнах.
  • Повышает вашу продуктивность на 50% и сокращает количество щелчков мышью на сотни каждый день!
офисный дно
Сортировать комментарии по
Комментарии (2)
Оценок пока нет. Оцените первым!
Этот комментарий был сведен к минимуму модератором на сайте
Спасибо за полезную статью. Интересно, что =СРЗНАЧ($A$5:$A$1000,$A8,ABS($AH$5:$AH$1000)) выдает ошибку, а =СРЗНАЧ(IF($A$5:$A$1000=$A8,ABS( $AH$5:$AH$1000))) нет. Это потому, что AVVERAGEIF ожидает только диапазон ссылок на ячейки?
Этот комментарий был сведен к минимуму модератором на сайте
Ты прав.
Здесь еще нет комментариев
Оставляйте свои комментарии
Публикация как гость
×
Оценить этот пост:
0   Характеристики
Предлагаемые места

Подписывайтесь на Нас

Copyright © 2009 - www.extendoffice.ком. | Все права защищены. Питаться от ExtendOffice, | Карта сайта
Microsoft и логотип Office являются товарными знаками или зарегистрированными товарными знаками Microsoft Corporation в США и / или других странах.
Защищено Sectigo SSL